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ReportWorks 
ReportWorks is PowerSchool’s new reporting tool. ReportWorks is designed to give PowerSchool 
administrative users a drag-and-drop interface for creating custom reports.  

In this class, you will learn to create the following types of reports: 

• Mailing labels 

• Student lists 

• Student schedules 

• Cross Tab 

• Form letters 

Getting Started 
To access ReportWorks, log on to PowerSchool and use one of the two paths:  

1. On the Start Page main menu, click ReportWorks 
 
or 

2. On the Start Page main menu, click Reports > Setup > ReportWorks 

3. On the Launch ReportWorks page, click Launch 
 
ReportWorks will launch as a separate application using Java™.  
 
Your username and password are the same as the username/password for logging into 
PowerSchool admin. The only case where this is not true is if the user is also setup to access 
PowerTeacher Administrator and within PowerTeacher Administrator the user changes the 
username/password. When this occurs, the user will need to use the PT Admin 
username/password to access ReportWorks. 

4. Enter the username and password, and click Login. 
 
When you log on, the ReportWorks start page gives you three choices: create a report project 
from a template, start a new report project from scratch, or open an existing report project. 
 
In the first activity, in order to become familiar with how ReportWorks works, you'll look at a 
report project based on a template. 

 

Activity 1: Student Schedules from a Template 
First, look at an example of a pre-fabricated report project in ReportWorks that can do almost 
everything you need to do with Student Schedules. When you need a report in a hurry, templates are 
a good way to go. 

1. Log on to ReportWorks, and click Project based on a template 

2. Select Student Schedule List, and click Create 

3. Click the Layout tab, and click Preview; you'll see examples of the student schedules 
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4. Click Edit to look at how the report is set up 

5. You’ll see several data objects arranged on the report project's grid: 
 

 

6. Every data object has an @ sign at the beginning and at the end; between @’s you see the 
field name and its table location in this order: parent.child.fieldname; for example: 
@Student.Enrollment.School_Name@ 

7. To get more information about how the report is constructed, click Tools > Inspector 

8. In the lower left corner of the table in the Layout, click Table Group. The Table Group 
Inspector will list the two levels of the report project. The outer level is the student's general 
information, while the inner level is the student's schedule information 

9. Click the Class_Enrollments level in the Inspector to see how the student's schedule 
information is arranged: 
 

 

10. Also in the lower left corner, you’ll notice that the author of this report has incorporated a date 
stamp; click the date stamp to see in the Text Inspector how it was created 

Creating Labels 
Labels are about the simplest, most straightforward report in ReportWorks. The dimensions of the 
labels are already set; all you have to do is choose which brand and label number you want; then 
arrange the text in the labels. 

Activity 2: Create Mailing Labels 
In this activity, you'll create a basic Avery 5160 label with the student's first name, last name, 
address, city, state, and zip. You will also set a Boundary (filter) that will confine the report to active 
students only. 

1. To start a new report project, click +add in the upper-left corner of the screen, and choose 
Add Project 

2. The new report project will be named Untitled Report 

3. Right click Untitled Report and select Load Report 

4. Click the Details tab, and give your project a title that includes your initials, such as Student 
Mailing Labels_gb 

5. Give your project a description, such as Avery 5160 labels 

6. For the Data Set, click Student : Basic.  

7. Click Scope to set Boundaries (filters) and Runtime Controls (choices of groups of students) 

8. Click Boundaries 
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9. In the bottom part of the page, click Student to expand the data set 

10. Click Demographic to expand that set 

11. Drag Student_enrollment_status into the main part of the page 

12. Make sure the operator in the Add Filter box is set at = 

13. Type 0 in the field after the operator, and click OK 

14. Click Layout 

15. From the Data Set at the bottom part of the page, drag the Student data object into the main 
part of the page 

16. On the Dataset Key Element box that appears, click Labels, then click OK 

17. Click in one of the labels, and on the right of the ReportWorks toolbar, click  to open the 
Inspector  

18. In the Labels Inspector, under Avery Product Number, choose 5160: Address Labels 

19. Double click inside the first label so that it has a light-red border around it 

20. In the Data Set at the bottom of the page, click Contact to expand that set of data objects 

21. Drag the FirstLast_Name data object to the first label 

22. Move your cursor to the bottom, left corner of the FirstLast_Name data object and resize 
that object to match the size of the label 

23. In the Text Inspector, click after the FirstLast_Name data object 

24. Press ENTER/RETURN to start a new line 

25. Drag the Mailing_Street data object onto the FirstLast_Name data object 

26. In the Text Inspector, click after the Mailing_Street data object 

27. Press ENTER/RETURN to start a new line 

28. Drag the Mailing_City data object onto the the FirstLast_Name data object  

29. In the Text Inspector, click after the Mailing_City data object and type a comma and a space 

30. Drag the Mailing_State data object onto the the FirstLast_Name data object 

31. In the Text Inspector, click after the Mailing_State data object and type a space 

32. Drag the Mailing_Zip data object onto the the FirstLast_Name data object 

33. Enlarge the field, so that it fits the entire label: double click in the cell so that the resizing 
handles appear; place your cursor on the bottom right corner and drag it to fit 

34. Click Preview 

35. Click Edit to close the preview 

 
Activity 3: Add a Logo to Your Labels 
Now it's time to personalize your labels with the school mascot. 

1. Click the first label, so that it has a light-red border around it 

2. On your PSU CD, go to the ReportWorks folder, and find the file called mini_tiger.png  

3. Re-size the ReportWorks window so that you can see both it and the mini_tiger.png file at the 
same time 
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4. Drag the mini_tiger.png to the first label 

5. In the Image Import box, click Image Shape 

6. Re-size the label text, so that the image has room 

7. Click the Tools menu and choose the Font Panel; change the font of the label text to be 10 
point 

8. Click Preview to see your results 

9. Click Edit to close the preview 

 

Creating Student Lists 
Labels were a snap with ReportWorks. Now it’s time to turn your attention to a different report 
project. This project will show you how to use some of the design features in ReportWorks. You'll start 
by getting students' names, gender, and ethnicity; then you’ll sort that student list by students’ last 
names.  

Activity 4: Create a Simple Student List 
1. Start a new report project: click +add in the upper-left corner of the screen, and choose Add 

Project 

2. The new report project will be named Untitled Report 

3. Right click Untitled Report and select Load Report 

4. Give your project a title that includes your initials, such as Simple Student List_gb; then 
give it a description 

5. Select the Student : Basic Data Set 

6. Click the Scope tab  

7. Click Layout 

8. From the Data Set at the bottom of the page, drag the Student data set into the main frame 

9. For the Dataset Key Element, click Table and then OK 

10. Click Contact to expand the set 

11. Drag Last_Name to the first cell of the table 

12. Drag First_Name to the second cell of the table 

13. Click Demographic to expand the set, and drag Ethnicity to the third cell of the table 

14. Drag Gender to the fourth cell of the table 

15. Re-size the placeholder, so that it takes up the entire page 

16. Click Preview; you'll see a sample list of students 

17. Click Edit to close the preview 

Activity 5: Format the Student List 
The list is working well so far; you have appropriate spacing between the students. But it's quite plain. 
It could use a little bit of dressing up. In this activity, you'll change fonts and colors, and add a header 
to your report project. 
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1. Re-size the first and second columns so that they take up most of the row 

2. Re-size the third and fourth columns, so that each column width is appropriate to the data; 
remember, the full data object name might be @Demographic.Ethnicity@, but you have to 
make the column only wide enough to show one letter 

3. Now you're going to put the school name at the top of each page; click the Table Inspector, 
and click Header 

4. Drag School_Name into the first cell of the Student Header 

5. Click in the Text Inspector after the School_Name data object; type a space and Student 
Roster 

6. Click the box next to the word Standard on the “Student Header” to merge the four cells into 
one 

7. Click the Tools menu and choose the Font Panel 

8. Select the Student Header text and use the Font Panel to change the font size to 18 bold 

9. Re-size the placeholder to be tall enough for the text, and as wide as the table 

10. Use the Text Inspector to center align the text in the placeholder 

11. Click the outer border of the header, so that it has a light-red line around it 

12. Click the Paint/Fill Inspector (paint bucket), and click Fill 

13. Click the black square, and choose a different color 

14. Click Preview to see your progress 

15. Click Edit to close the preview 

Activity 6: Alternating Row Colors 
So, you have a colored background for your page header. But what about the rows of student names 
themselves? Wouldn't they benefit from a little color, too? The problem is, if you make every row the 
same color, nothing really stands out. It would be better to use a color for every other row. 

1. Click the word Standard on the Student Details row 

2. Choose Add Alternate so that you can have a different color for the alternate rows 

3. Click the Paint/Fill Inspector (paint bucket), click Fill, and choose a color; your best bet is 
to use a light, subtle gray color 

4. Click Preview to see how the data will look; the gray rows will be the even-numbered ones 

5. Click Edit to go back to the design of your table 

6. Click the word Alternate on the Student Details row, and choose Standard; use the Paint/Fill 
Inspector to give the odd-numbered rows their own color 

7. Click Preview to see how it looks 

8. Click Edit to close the preview 

Activity 7: Sort the Data and Add a Page Number  
You've previewed the report a couple of times. You can see that the report will clearly span more than 
one page. Now that you know that, it makes sense to have page numbers so that when you print the 
report, it's easier to keep the pages in order.  

Now you'll sort the students by last name, making the data easier to read. 

Sorting 
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1. Click inside the table, then click Table Inspector on the Inspector Pane 

2. Click Contact, then click Last_Name and drag the Last_Name data object to the Sort area 
of the Table Inspector 
 
Page Numbering 

3. In the Data Set’s first column, click Page of PageMax and drag it to the bottom of the page, 
below the edge of the table  

4. To get the page number to the center of the page, expand the placeholder so that it's the 
width of the page, and then center align the text using the Text Inspector 

5. Click Preview 

6. Click Edit to close the preview 

 

Creating a Report Containing a Student Schedule 
How many times during a school year do you need a document containing a student class schedule? 
With ReportWorks you can make a report that is just a table containing the schedule, or you can place 
a schedule in other types of documents, such as a letter to parents. A convenient template is included 
with ReportWorks, making this project very easy to create. 

Activity 8: Create a Student Schedule 
1. Log on to ReportWorks, and click Project based on a template 

2. On the list of templates, click Student Schedule List, and click Create 

3. Name and describe the project (include your initials in the name), and make sure the Data Set 
is Student : Basic + Schedule 

4. Click Scope and set up appropriate Boundaries and Runtime Controls 

5. Click Layout; then click Preview to see whether the template pulls the information you want 
in your report 

6. Click Edit, and using the techniques you’ve learned in this course, modify the project to fit 
your needs 
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Creating a Cross Tab Report 
The Cross Tab Report in ReportWorks is similar to a PivotTable in Excel. It's a report that shows how 
sets of data intersect; for example, it could show student populations broken down by both gender 
and ethnicity. The Cross Tab report project layout looks like this: 

 

 

 

 

 

 

 

 

 

 

1. Column field – one unique value in each column 

2. Row field – one unique value in each row 

3. Data field – where the column meets the row 
 

You can use a data object modifier such as “count” to get the results you want. “Count” is one type of 
modifier in the group called Aggregate Modifiers, which can be used as in this example: 
 
Aggregate Modifiers 

Format: @[modifier].[Data Object]@ 

Example: @count.Ethnicity@ 

Result: Displays count of each Ethnicity code within a group in a table 

Modifier Description 

total Calculates the total for numerical values 

average Calculates the average for numerical values 

count Provides a count of how many data objects are in a list or group 

max   

min   

 

2 

3 

1 
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Activity 9: Create a Demographics Summary 
1. Click +add under the Projects pane to start a new report project 

2. The new report project will be called Untitled Report; right-click the name and then click Load 
Project 

3. Click the Details tab; change the Project Name to Student Demographics, and give it a 
description 

4. For Data Set, choose Student : Basic 

5. Click Scope 

6. In the Data Set pane, click Student to expand the data set 

7. Set a Boundary by clicking Demographic 

8. Drag Student_enrollment_status into the Boundaries pane 

9. Make sure the operator in the Add Filter window is = 

10. Type 0 in the blank field 

11. Click Layout 

12. Drag the Student data object to the Layout pane, choose Cross Tab from the Data Key 
Element dialog, and click OK 

13. Click Demographic to expand the object, and drag Gender to the Column field 

14. Click Ethnicity and drag it to the Row Field 

15. Click in the Data field, and type @count@  

16. Click Preview to see your results so far; then click Edit to make further changes 

Activity 10: Change the Cross Tab Report's Format 
The report is showing useful data. But the format could be a little better. Fortunately, ReportWorks 
has built-in formats to help make your data stand out a little better. In addition, since this is sensitive 
information, you'll add a watermark to your report – the word CONFIDENTIAL. To make the 
watermark easier to manage, you'll explore how to use layers in ReportWorks. Using layers will help 
you move the watermark independent of the Cross Tab data. 

1. Click the border of the Cross Tab to activate the Cross Tab Inspector 

2. At the bottom of the Inspector window, click AutoFormat 

3. Choose Classic 3 for Table AutoFormat, and click OK 

4. Click Preview to see the results 

5. Select the Page Inspector on the Inspector pane, to add a new layer for the watermark 

6. Click Add; then click Rename 

7. Rename your new layer Watermark  

8. Click the eye next to Layer 1, to temporarily hide the Cross Tab data 

9. Re-size the ReportWorks window so that it takes up about half of your screen 

10. On the PSU CD, navigate to the ReportWorks folder, and click the file called Watermark; drag 
the file to the ReportWorks window 

11. Click Layer 1, and then click Rename; call this layer Data 
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12. Click the eye next to Data to make it visible again 

13. Click the layer Watermark, then click and drag the watermark to move it around 

The advantage to putting the watermark in its own layer is that it's easier to manage independent of 
the data. In the next activity, you’re going to use an existing form letter in conjunction with 
ReportWorks, and you'll see that being able to show and hide will be incredibly useful. 

 

Using ReportWorks to Fill in Forms 
It might be a letter to parents, it might be a 504 plan, it might be a permission slip. You can't get too 
far in your school day without having to fill out a form for multiple students. ReportWorks has some 
tools to make this a little bit easier. 

You'll go through two different examples. In the first example, you'll use an existing permission slip, 
which is in a PDF format, and use ReportWorks to help fill in the fields. In the second example, you'll 
copy and paste some text directly into the ReportWorks window, and edit the text. 

 Activity 11: Use a PDF Letter, and Add Data objects 
In this activity, you already have a PDF form letter that you can just drag and drop into the report 
project Layout window. 

1. Create a new report project, titled PDF Form Letter 

2. For the Data set, choose Student : Basic  

3. Click Scope 

4. Click Layout  

5. Drag the Student data object into the layout 

6. For the Data Key Element, choose Table, and click OK 

7. Resize the table to take up the entire Layout page 

8. Re-size the ReportWorks window so that it takes up only half the screen 

9. On your PSU CD, go to the ReportWorks folder, and find the file called Permission_Slip.pdf 

10. Drag the Permission Slip file to the Layout window 

11. In the Image Import box, click Image Shape 

12. Click Tools > Inspector, so that you can manage your document's layers 

13. Click Page Inspector so that you can see the existing layer, Layer 1 

14. Re-name Layer 1 as Background 

15. Click the lock, so that the background layer with the school letterhead does not move 

16. Click the letterhead in the layout area, and try to move it 

17. Go back to the Page Inspector, and click Add so that you create a second layer 

18. Rename the second layer Data  

19. Click the Data layer, so that the data objects you add will be on that layer 

20. Drag FirstLast_Name to the line that reads To the parents of _______ 

21. In the first column of the Data Set, click Date and drag Date to the line that reads Date: 
______ 
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22. Click the Tools menu and then click Format Panel 

23. Click Mar 8 to change the date format 

24. Change the date format to MMMM d, YYYY 

25. Click Preview to see an example of your work 

26. Click Edit to close the preview 

 

Activity 12: Create an Impromptu Form Letter  
Sometimes you have a form letter file that a colleague has given you. It's not quite what you need, 
but it's a good start. 

Using ReportWorks, you can take the existing text and modify it for your purposes. 

1. Create a new report project, titled PDF Form Letter, and choose the Student : Basic data set 

2. Click the Scope tab, and set whatever Boundaries and Runtime Controls are appropriate 

3. Click Layout 

4. Drag the Student data object to the Layout area 

5. For the Dataset Key Element, click Table and then OK 

6. Re-size the table, so that it takes up the whole page 

7. You want to have only one student's name per page; click Tools > Inspector; the Table 
Inspector should be active 

8. Under the word Grouping, click the gray square next to the word Student; the button will 
change from a gray square to a picture that looks like a torn piece of paper: 
 

 

9. Double click Student Details in the gray area to make that row active 

10. Click the button next to the word “Standard” so that the four cells become one 

11. Move your cursor to the top of the gray row, so that your cursor becomes a double-headed 
arrow:  
 
 

12. Click and drag the Student Details gray area down to the bottom of the table so that you 
have the maximum area to work with 

13. Click and drag the FirstLast_Name data object to the middle of the page 
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14. Resize that field to about half of the page so that you have some extra room to add text 

15. Double-click the text box to add text to it 

16. From your PSU CD, open the file called permission slip.rtf,  

17. Copy the text from that file, and paste it into the ReportWorks window 

18. Edit the line which reads “no later than __________”; replace the underline with a date 

19. Click Preview 

20. Click Edit to close the preview 
 

Publishing and Unpublishing a Project 
In order to use your reports in PowerSchool, you must publish them. Publishing a project makes it a 
report. Once you have published a report to a school, it appears in that school’s list of ReportWorks 
reports. The only way you can remove a report from PowerSchool’s list is to go back into ReportWorks 
and unpublish it.  

Activity 13: Publishing a Project 
1. After you finish a project, click the Publish tab 

2. Give your report a name and a description 

3. Select the Output Type 

4. Select the PowerSchool Application that will use the report 

5. Select an appropriate category 

6. Select the schools that will use the report and click the arrow pointing to the Published Schools 
box 
 
After you choose the schools, the Security Groups function becomes active. 

7. Select the security groups who need access to the report and click the arrow pointing to the 
Published Security Groups box 

8. Click Publish 

Activity 14: Unpublishing a Project 
1. Launch ReportWorks 

2. Right click the name of the project, and click Load Report 

3. Click the Publish tab 

4. At the bottom of the page click Unpublish 

 

Managing and Using ReportWorks in PowerSchool  
PowerSchool administrators must set up ReportWorks within PowerSchool: 

• Set report categories 

• Set preferences 

• Give access to ReportWorks Developer users 
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Report categories are needed in the publishing phase of creating a report. The categories you 
establish here populate a dropdown menu on the Publish page. 

In ReportWorks Preferences you will edit report queue and developer preferences. 

Activity 15: Setting Categories and Preferences 
1. Log on to PowerSchool 

2. On the main menu click System > ReportWorks Administration 

3. On the ReportWorks Administration page, click Report Categories 

4. Click Add New Report Category 

5. In the blank field, type the name of a category for a type of report. You might have reports 
that contain only demographic information, so a Demographics category could be made 
available. 

6. Click Submit 

7. Repeat steps 4, 5 & 6 for all the categories you need 

8. Click ReportWorks Administration in the breadcrumbs; then click ReportWorks 
Preferences 

9. For the ReportWorks Scheduler Node, type the IP address of the node in your system where 
Reports will be run 

10. Enter the IP address of the load balancer 

11. For the Number of Concurrent Report Jobs, select the number of report jobs that can be 
running at the same time 

12. For the Completed Report Retention Period select the number of days that reports will be 
retained in the ReportWorks queue 

13. For the ReportWorks Application Timeout, set the number of minutes of inactivity before the 
ReportWorks developers’ report creation application requires re-login 

14. Click Submit 

 

ReportWorks report developers need permission to use the ReportWorks report creation application. 
You give this permission in the user’s Security Settings. 

Activity 16: Setting Up ReportWorks Developer Users 
1. Log on to PowerSchool 

2. Navigate to the record of the staff person to be a ReportWorks Developer 

3. In Security Settings, select Yes on the line for “ReportWorks Developer user?” 

4. Click Submit 

 

Using ReportWorks Reports in PowerSchool 
Running a ReportWorks report is very intuitive except for a couple of things: 

• ReportWorks reports have their own location in PowerSchool—a tab on the Reports page 

• ReportWorks has its own report queue 
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So, here’s how you use it. 

Activity 17: Using Reports in PowerSchool 
1. Log on to PowerSchool 

2. Click Reports 

3. Click ReportWorks 

4. The reports will be sorted by category. Click the name of the report you want to run 

5. On the report’s Runtime Parameters page, select the appropriate parameters for your desired 
results 

6. Under Scheduling, select Run Now, and click Submit 

7. In the Report Queue, you will see two tabs; click ReportWorks if it is not already selected 

8. Your report will be in the Queued Reports panel. If its status says Pending, at the top of the 
pane, click Refresh occasionally until the job’s status says Completed 

9. When the report’s status says Completed, click Completed 

10. Your report will be displayed in whatever format was chosen at the time the report was 
published in ReportWorks 


